EIGRP (Enhanced Interior Gateway Routing Protocol)

2013 yılına kadar Cisco’ ya özel Dynamic  router protokolüdür. Günümüzde endüstri standartı haline gelmiştir. (DMVPN ) Hybrid özelliktedir. Yani Distance ve Link state protokol özelliklerini taşır.

  • Metric olarak varsayılanda bandwidth ve delay değerlerini kullanır. Ancak istenilirse reliability ve load değerlerini kullanması istenebilir.
  • Dual algoritma (Diffusing update algorithm) ile routing tablosunu ve topogy tablosunu oluşturur.
  • Hızlı bir şekilde converge olur. [Topology tablosunda yedek rota (Feasible successor) tutar]. Successor devre dışı kaldığında Feasible successor rotasını Successor yapar ve route tablosuna yazar. Böylece çok hızlı bir şekilde converge olmuş olur.
  • Administritive distance değeri 90 dır.
  • Max hop count değeri 255 Varsayılanda 100 dür.
  • Kullandığı multicast adresi ipv4 için 224.0.0.10, ipv6 için 01-00-5E-00-00-0A dır
  • VLSM ve CIDR desteği vardır.
  • Çoklu L3 protokol desteği vardır. (IP, IPX,APPLE TALK)
  • Sınırlı güncelleme (bounded update) yapar. Routing table tamamı değil sadece değişen kısım güncellenir.
  • Kendi arasında cisco’ya özel olan RTP (Reliable Transport protokol)protokolünü kullanır. RTP TCP gibi güvenli iletişim protokolü olup Layer 3 de çalışır. RTP 88 portunu kullanır.
  • Hello interval time: 5 sn, Hold time 15 sn dir. 3 defa hello paketine cevap gelmezse komşuluğunu düşürür.
  • EIGRP birbirine bağlı olarak 3 adet tablo tutar. (Neighbor Table, Topology Table, Routing Table)
  • EIGRP AS number komşu olunacak  routerlarda aynı olmalıdır.  Aynı olmayan routerlar arasında manuel olarak redistribution yapılabilir. Aksi taktirde routerlar birbiriyle iletişime geçmeyecektir.  Ayrıca komşuluk olma şartı AS number  ile birlikte K değerleri (K1 ve K3) ve authentication bilgileride aynı olması gerekir.
  • EIGRP, harici bir paketten gelen update bilgisini Routing table da  EX(External) olarak belirtir.

Kısaca Çalışma Mantığı:

RIP ve IGRP belirli zaman aralıklarında routing table (bildiği network adreslerini) yollar. Bu durum ağda trafik oluşmasına sebep  olur.  EIGRP tüm Routing table göndermektense küçük hello paketleri yollayarak komşu routerların up / down olup olmadığını kontrol eder. Komşu routerlar hello paketlerine cevap olarak ACK paketleri yollar.  Böylelikle routerın up olduğunu anlar. Ortama yeni bir router eklendiğinde veya çıkarıldığında  Query paketi yollar yolladığı paketin cevabı olan Reply paketi ile komşu routerlar hakkında bilgi edinip  Dual algoritmasını kullanarak Topolgy tablosunu oluşturur.

EIGRP paket türleri

  1. Hello (5sn) (Multicast)
  2. Update (Unicast-Multicast)
  3. Acknowledgement (Unicast) (Data içermez)
  4. Query  ( Multicast- Unicast )
  5. Reply (Unicast)

Hello packet: 224.0.0.10 ip adresi üzerinden gönderilir. Komşulukları belirlemede ve bu komşulukların bitişikliğini (adjacency) belirlemede kullanılır. Güvenli protokol üzerine iletişim kurmaz(RTP kullanmaz) böylelikle güvenli değildir. Hello paketlerine cevap beklenmez. Hello paketleri 5 saniyede  bir kez yollanır. Hold time 15 sn dir.  Router 5 saniyede 1 kez Hello paketini yollar. Komşu router 15 saniyede cevap vermek zorundadır. Cevap vermezse router komşuluğunu düşürür.

R2(config-if)#ip hello-interval eigrp 1 10 (sn)

R2(config-if)#ip hold-time eigrp 1 60 (sn)

Update packet: Routing bilgilerini yayınlamada kullanılan paket türüdür. Metric hesabında değişiklik olduğunda, Successor değiştiğinde ,  yeni bir network bulunduğunda ve komşuluk kurulduktan sonra kendi üzerindeki network bilgilerini yollarken update paketini kullanılır.

Query packet: Dual tarafından networklerin araştırılmasında kullanılır. Sorgu yapan paketlerdir. Sahip olduğu networkte kaybolma olan router query paketleri yollayarak networkünü aramaya çalışır. Query yollayan router’a active router denir.

Reply packets: Ouery paketlerinin cevabıdır. Dolayısıyla Dual tarafından kullanılır. Daima unicast olarak çalışır.

ACK (Acknowledgement): Data içermez ama güvenli iletişimi sağlar. Onay paketleridir.

Ör:

eigrp

R1 router’ında 10.0.0.0/8 network down olduğunu ve Feasible Succesor olmadığını varsayalım. 

 

  1. R1 router R2 ve R3 routerına 10.0.0./8 ağının  down olduğunu belirten multicast update paketi yollar
  2. R2 ve R3 bu pakete karşılık onay paketi olan ACK paketini R1 routerına yollar. (R1 in yolladığı Update bilgisini aldığını karşı tarafa iletmiş olur)
  3. R1 10.0.0.0/8 ağı için yeni bir yol olup olmadığını keşfetmek için bütün komşularına Query paketi yollar.
  4. R2 ve R3 query paketine karşılık olarak ilk başta paketi aldığını ileten ACK sonrasında Reply cevabını R1 routerına yollar. (R2 ve R3 router’larında 10.0.0.0/8 network ait herhangi bir bilgi yoksa R2 ve R3 router’larıda var olan komşularına Query  paketi yollar.)

EIGRP Metric Hesabı

show ip protocols  (K değerleri görülür)

K1 > bandwidth (1),      K2 > load (0),       K3 > delay (1),       K4 > reliability (0),      K5 >  reliability (0)

Defaultta K1 ve K3 değerleri kullanılır. ve dolasıyla çarpanları 1 dir. Diğer K değerlerinin çarpanları 0 (sıfır) olduğundan dolayı hesaplamada geçersizdir.

  • Default olarak EIGRP K1(Bandwidth) ve K3 (Delay) değerlerini kullanır.
  •  metric=[K1 X Bandwidth+(K2 X Bandwidth)/(256-load)+(K3 X Delay)] X [K5 / (Reliability+K4)]
  • Default olarak K2 K4 K5 değerleri 0 sayılır. Böylelikle  metric=256X [(K1 X BW)+(K3 X Delay)] K değerleride 1 olduğu için formül metric= 256X [BW+DELAY]  Delay= Toplam gecikme (milisaniye)   Bw= 10⁷ / Rotadaki en düşük bandwidth (kbps)

       R(con-router)#metrics weights 0 ‘K değerleri’

  • K değerleri her routerda aynı olmalıdır.
  • Bandwidth : Varsayılan olarak 1544 kbps dir.
  • Reliability :Otomatik hesaplanır 255/255 demek %100 güvenli anlamına gelir. 
  • Load: Trafik miktarını gösterir. Mümkün olduğunca düşük değer olmalıdır. 1/255 değeri 246/255 değerinden daha uygundur.
  •  show ip eigrp topology 192.168.2.0 komutu o rotadaki (ör: 192.168.2.0) minimum bandwidth, toplam gecikme gibi bilgiler görünebilir.  
  • EIGRP varsayılan olarak 4 linke kadar equal-cost yük paylaşımını destekler. R(con-router)#maximum-paths 1 6 komutu ile 1 ile 6 arasında değiştirilebilir.

EIGRP TABLOLAR

EIGRP birbirine bağlı olarak çalışan 3 tane (Neighbor table, Topology table, Routing table) tablo  kullanır.

1- Neigbor table

eigrp_neighbors 

H(Handle): Cisco ios tarafından komşu takibi için kullanılan sayıdır.

Address: Komşu routerın ip adresi

Interface: Komşu routera bağlı olan local arayüz

SRTT: Hello paketin karşıya routera iletilme süresi (40 ms karşı routera iletilmiştir)

Seq number: Her komşuluk kurulunca EIGRP de bir seq number atanır. Bu seq number komşusu olan router ile aynıdır.

Q Cnt: Kuyrukta gönderilmesi beklenen paketler

  • Doğrudan bağlı komşu routerların bilgilerini tutar.
  • Router komşuya hello paketi gönderdiğinde buna bir cevap bekler. Belli bir süre (hold-time) cevap gelmezse komşunun down olduğunu kabul ederek DUAL yeniden topolojiyi hesaplar.

2- Topology table

 show ip eigrp topology

eigrp_topology_table

P (Passive): Network ulaşılabilirdir. Routing tablosuna kayıt başarıyla aktarılmıştır. Dual’in anlık olarak çalışmadığı anlamına gelir.

A (Active): Network ulaşılamaz durumdadır. Dual çalışıyordur. Routing tablosunda hedef için rota yoktur.

S (Stuck in active status) EIGRP convergence problemi vardır.

EIGRP hedef networklere gitmek için kullanacağı yolların bilgisini tuttuğu tablodur. Bu tabloda bulunan bilgiler kullanılarak Successor ve Feasible Successor seçilir.

Feasible Distance: Successor rotanın (en iyi yol) metric değeridir. Bir hedefe giden  yollar arasındaki metric olarak en iyi değerdir. Feasible distance topology tablosunda en iyi değer olduğu için routing tablosuna aktarılır. Successor Route olarak  routing tablosuna yazılır.

Advertised (tanıtılan) Distance : Komşu tarafından bildirilen en iyi ölçevdir. Komşunun hedef networke olan uzaklığıdır. Reported distance olarakta geçer.

Successor route: Dual algoritmasının kullanılması sonucunda oluşturulan en iyi yoldur. (routing tablosunda bulunur)

Feasible Succesor: Dual algoritmasının kullanılması sonucunda oluşturulan en iyi ikinci yoldur. Topology tablosunda yedek rota olarak bekler.  (Successor route down olduğunda routing tablosuna successor route olarak atanır)

3- Routing table

eigrp_show_ip_route

  • Successor (Best route) olarak seçilen yolun bulunduğu tablodur.
  • Successor seçilirken yolara ait metric toplamlarının (Her birinin feasible distance değerlerinin toplamı) en küçüğünü kullanır. Feasible distance eşit ise en düşük reported distance (Bir sonraki router için geçerli olan feasible distance değeri)sahip olan yol seçilir.

Ör: Router A dan çıkan paketin Network Z ye yollanması

En iyi feasible distance değeri en düşük Router C olduğu için paket Router C aracılığı ile gönderilir.

Not: Feasible Succesor’ ın Advertised Distance değeri  (10) < Succesor rotanın Feasible distance değerinden (20)

EIGRP Summarization

Özetlemenin amacı routing table küçültmektir. Böylelikle routing tablosunda arama ve  güncelleme performansı artırılmış olunur. EIGRP default olarak summarization yapmaktadır. manuel özetleme yapmak için otomatik özetlemeyi iptal etmek gerekmektedir. Bunun için no auto summary  komutu kullanılır.

 Manuel Summarization

  1. İlk olararak otomatik özetleme iptal edilir (no auto summary komutu kullanılır)
  2. Aşağıdaki komut kullanılarak özet adres belirtilir.

R(Config-if)# ip summary-address eigrp AS number

ip address    wildmask [Administrative distance]

ör: 10.0.0.0/16   10.1.0.0/16     10.2.0.0/16      10.7.0.0/16 manuel özetleyiniz?

eigrp_ozetleme

LOAD BALANCING

Routerların EIGRP metric değerlerinin aynı olma ihtimali zordur. Bu nedenle Rip v2 deki gibi load balancing düşünülemez. EIGRP Farklı metric değerlerinde load balancing ( Unequal Cost Path Load Balancing ) yapabilir.  Eigrp sadece feasible successor rotaları load balancig de kullanır. Belirli bir değer belirtilir (variance değeri) ve en küçük metric değeri (Feasible distance) ile variance değeri çarpılır. Çıkan sonuç altında kalan metric değerlerine sahip yollar  arasında load balancing yapılır.  Defaultta 4 yola kadar ama max 32 yola kadar load balancing yapabilir. Komut olarak variance n komutu kullanılır. Variance değeri 1 yapıldığında load balancing devre dışı kalacaktır. Variance router bazlı değişkendir.

AUTHENTICATION

EIGRP routing bilgilerini şifreleyerek yollayabilir. Böylece güvenlik artırılmış olur.

Komut:

R(config)# key chain zincir_adı

key numara

key-string parola (bütün routerlarda aynı olmalı)

R(config-if)# ip authentication key-chain eigrp AS_NO zincir_adı

EIGRP KONFİGÜRASYON

Router(config)# router eigrp AS_NO

network network_id wildcard_mask (Routerın sahip olduğu network bilgileri)

EIGRP ile FARKLI ROUTING PROTOKOLU İLE GÖRÜŞTÜRME (redistribute)

Farklı routing protokole sahip routerlar aralarında görüşebilirler. bunun için redistribute komutu kullanılır. Aşağıdaki örnekte EIGRP  ile OSPF protokolleri arasında redistribute işlemi anlatılmaktadır.

ör:

eigrp_redistribute_ornek

RA(config)# router ospf 10

                        network 192.168.1.0 0.0.0.255 area 0

RA(config)# router eigrp 100

                        network 10.8.8.0 0.0.0.255

                         redistribute  ospf 10 metric  10000 100 255 1 1500 [(1000 kbps cinsinden bant genişliği) (100 Gecikme değeri)  (255 kararlılık değeri), (1 routerlar arası metric  değeri)  (1500 mtu)

RA(config)# router ospf 10

redistribute  eigrp 100 subnets (subnets parametresi girilmezse classful olarak çalışır, classless çalışması için subnets parametresi unutulmamalı)

RB(config)# router eigrp 100

                       network  172.16.1.0 0.0.0.255

                       network 10.8.8.0 0.0.0.255

Not: Eigrp farklı AS arasındada redistribution yapılabilir.

Eigrp Static redistribute

Router üzerinde oluşturulan static rotalar Eigrp üzerinden network’e duyurabiliriz.

R1(config)#ip route 0.0.0.0 0.0.0.0 Loopback1  (Static rota oluşturulur.)

R1(config)#router eigrp 1  (Static rota Eigrp üzerinden duyurulur.)
R1(config-router)#redistribute static

Eigrp Stub

Tree yapısındaki en uç dal gibidir. Stub router’lar eigrp tarafından öğrenilen route’ları diğer komşularına iletmezler.  Ayrıca stub olmayan router’lar stub olan router’lara query paketleri yollamazlar. Yani stub router’lar query paketi geçirmezler ama update paketi geçirirler. Stub ile gereksiz query paketleri iletilmediği için band genişliğinden tasarruf edilmiş olunur. 

eigrp stub: Default olarak eigrp stub komutu ile stub olan router komşuları ile connected ve summary route’larını paylaşır. 

Recieve only: Sadece update alır. Komşularıyla herhangi bir route paylaşmaz.

Static: Static route’ları komşuları ile paylaşır.

Connected: Connected route’ları komşuları ile paylaşır 

 

 

Share