WAN BAĞLANTI TÜRLERİ

WAN (Wide area network) Geniş alan ağı, birden fazla cihazın birbiri ile iletişim kurmasını sağlayan fiziksel veya mantıksal büyük ağdır. Yerel alan ağlarının birbirine bağlanmasını sağlayan çok geniş ağlar olup en meşhur geniş alan ağı İnternettir. (Wikipedia)

Bağlantı türlerine gelmeden önce önemli WAN terimlerini açıklayalım.

CPE (Customer Premises Equipment): Servis sağlayıcıdan alınan hizmetin kullanılabilmesi için müşteri tarafından kullanılan cihazlara verilen isimdir. (Modem, router)

DCE (Data Communications Equipment):  Servis sağlayıcısının kullandığı sinyal türünü (sinyalizasyon) router’ın veya bilgisayarın anlayabileceği sinyale çeviren cihazdır. (modem, DSU-CSU)

DTE (Data Terminal Equipment): Router cihazlarına verilen genel addır.

Router-modem arası DTE kablo kullanılır.

Router-Router arası DCE kablo kullanılır. (Clock rate atanmalı)

Demarcation point: ISP’nin sorumluluğu bittiği ve kullanıcının sorumluluğu (CPE) başladığı noktadır. (Apartmana gelen kablo)

Local loop: Demarc’ı, central office denilen en yakın switching santraline bağlar.

Central office (CO): Müşterinin bağlı olduğu santraldir. Point of presence (POP) olarakta geçer.

WAN BAĞLANTI TÜRLERİ

1-) Leased line

Point to point bağlantı şeklidir. Upload ile download  hızları eşittir.  HDLC  PPP encapsulation sık kullanılan  protokollerdir.

2-) Circuit switching (Devre anahtarlama)

Asynchronous (Asekron) iletişim şeklidir. Yani upload ve download hızları birbirinden farklıdır. Telefon hatlarını kullanır ve düşük bant genişliğine sahiptir. (Dial-up, ISDN hatlar )

3-) Packet switching (Paket anahtarlama)

Bant genişliğini diğer kullanıcılarla paylaşma metoduna dayanır. Packet switching ile veriyi sürekli transfer edemezsiniz. Frame Relay, X.25, 56Kbps, T3

WAN ENCAPSULATION PROTOKOLLERİ

Data link layer protokolleri frame’in nasıl encapsule edileceğini ve gerekiyorsa ikinci katman adreslemesinin nasıl yapılacağını tarif eden protokollerdir.

Başlıca wan protokolleri Frame Relay, LAPD, LAPB, ISDN,  DSL, PPPoE, MPLS, HDLC, PPP, Kablo ve ATM. Bunların içinde PPP,  HDLCve Frame Relay seri interfacelerde kullanılır.

Not: Seri interfacelerde Ethernet veya Token Ring enkapsülasyon yapılandırılamaz. ( encapsulation ? komutu ile görülebilir. )

High-Level Data-Link Control (HDLC) Protocol 

IBM tarafından geliştirilmiş bit tabanlı  kiralık hatlarda (leased line) kullanılan bir noktadan noktaya protokoldür.

  • Data Link katmanında çalışır.
  • Her üreticinin HDLC uygulaması kendine özgüdür.   Yani Cisco HDLC ile başka cihazın HDLC haberleşemez.
  • HDLC cisco router tarafından senkron seri interfacelerde varsayılan enkapsülasyon metodudur.

HDLC

HDLC Konfigurasyon:

Haberleşecek olan ROUTER interfaceleri aynı şekilde konfigurasyon yapılır.

Router(config)#interface serial 0/1/0
Router(config-if)#encapsulation ?
frame-relay Frame Relay networks
hdlc Serial HDLC synchronous
ppp Point-to-Point protocol
Router(config-if)#encapsulation hdlc

Not: Router bağlı olan kablo hakkında bilgi edinmek için

Router#show controllers serial 0/1/0

interface serial 0/1/0

Hardware is PowerQUICC MPC860

DCE V.35, clock rate 2000000 DCE V.35 kablo türü

 

Point-to-Point Protocol (PPP) 

  • Bütün üretici firma tarafından desteklenen enkapsülasyon metodudur. (HDLC sadece aynı cihazlar arasında konfigurasyon yapılabilir)
  • PAP ve CHAP kimlik doğrulamayı destekler
  • Asenkron serial (dial-up) veya senkron (ISDN) kullanılabilen Data Link (veri iletim) Layer 2 katmanında çalışan enkapsülasyon metodudur.
  • NCP (Network control Protocol),  LCP (Link Control Protocol)  ve  HDLC (High Level Data Link Control) olmak üzere 3 tane protokolden oluşur.

LCP (Link Control Protocol)→  Hattın kurulması, sürdürülmesi ve sonlandırılmasından sorumludur. Poin to Point bağlantının kurulması için kullanılır. 5 farklı enkapsülasyon seçeneği vardır.

  1. Authentication (Kimlik doğrulama)→ PAP veya  CHAP yöntemleri ile linkler arası kimlik doğrulama yöntemi sunar.
    • PAP (Password Authentication Protocol) Güvensizdir. Kullanıcı adı ve şifreler clear text olarak yollanır. BöyleQlikle sniffer uygulamaları ile bilgiler yakalanır.
    • CHAP (Challenge Handshake Authentication Protocol). Güvenlidir. MD5 şifreleme kullanır.
  2. Compression (Sıkıştırma) 
  3. Error detection → Hattın kalitesini kontrol eder ve çok sayıda hata tespit ederse hattı kapatabilir
  4. Multilink – Load balancing
  5. PPP callback

NCP (Network control Protocol) →  Birden fazla Layer 3 (routed protokolleri)  protokolünün aynı anda taşınmasından ve eş zamanlı kullanımından  görevlidir.  Dolayısıyla PPP İçerisinde birden fazla Layer3 protokolü  taşıyabilir. 

HDLC (High Level Data Link Control):    Datagramların kapsüllenmesini sağlar

PPP Konfigurasyon:

OR_PPP

1-) Her iki routerda PPP enkapsülasyonu etkinleştirilir.

Router(config)#interface serial 0/1/0

Router(config-if)#encapsulation ppp

2-) PPP Authentication yapılandırılır.

  •  Router hostname ayarlanır.

Router(config)#Hostname R1

  • Router  username ve şifre verilir. (Username karşı routerın hostname dir) Her iki routerda şifre aynı olmalıdır.

R1(config)#username R2 password cisco1

  • Kimlik doğrulama metodu belirlenir (CHAP ve/veya PAP)

R1(config)#interface serial 0/1/0

R1(config-if)#ppp authentication chap

PPP compression

PPP nın verileri sıkıştırma özelliğidir.

RA(config-if)compress predictor/stac stac daha fazla ram ve cpu harcar. 

PPP multilink

PPP, birden fazla bağ üzerinde yük dengelemeyi destekler.

RA(config-if)ppp multilink

Doğrulama komutları

  • show komutu

R1#show interface serial 0/1/0

  • debug komutu

R1#debug PPP authentication

interfacelerde oluşabilecek sorunlar

R1#show interface serial 0/1/0

Serial0/1/0 is up, line protocol is up
Hardware is PowerQUICC Serial
Internet address is 10.0.1.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 239/255, txload 1/255, rxload 1/255
Encapsulation PPP
loopback not set
Keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP

1-) Serialx is up, line protocol is up → Birinci ve ikinci katmanda sorun yok

2-) Serialx is down, line protocol is down → Birinci katmanda sorun var. Dolayısıyla ikinci katman çalışmıyor. Birinci katman kontrol edilmeli

3-) Serialx is up, line protocol is down → DCE bağlı olan routerda clock rate girilmemiş olabilir, Kimlik denetimi varsa hatalı olabilir, Karşılıklı routerların layer 2 protokolleri aynı olmayabilir. (Biri HDLC diğeri PPP)

4-) Serialx is up, line protocol is up (loopad)   Test amaçlı loop verilmiştir.

5-) Serialx is up, line protocol is down (disable)   Routerın hat veya modemde oluşan sorunlardan dolayı interface kapatması (no shutdown ile açılır)

6-) Serialx is administratively down, line protocol is down interface shudown durumunda bırakılmıştır.

 

PPPoE YAPILANDIRMASI

PPPoE istemci olarak yapılandırmak

PPPoE destekleyen interface veya DSL modeme bağlı interface sahip olunmalıdır.

RA(config)# interface gigabitEthernet 0/0

RA(config-if)# pppoe enable group global

RA(config-if)# pppoe-client dial-pool-number 1

RA(config)# interface dialer 0   → Dialer interface oluşturulur.(Mantıksal interface)

RA(config-if)# ip address negotiated → ip adresini PPP ile alacağını belirtiyoruz.

RA(config-if)# ip mtu 1452

RA(config-if)# dialer pool 1 → dial pool 1 ve dialer-group 1 mantıksal ve fiziksel interface ilişkilendirilir.

RA(config-if)# dialer-group 1

RA(config-if)# encapsulation ppp → PPP authentication ayarlanır

RA(config-if)#ppp chap hostname burak

RA(config-if)#ppp chap password 0 cisco

FRAME RELAY

  • Frame relay bob-broadcast multi access (NBMA) ağı olarak sınıflandırılır. Broadcast göndermez
  • Frame relay noktadan noktaya leased-line gibi çalışmaz.
  • Frame relay leased-line göre daha az maliyetlidir.
  • Leased line gerçek devreler kullanılırken, frame relay sanal devreler kullanılır. (Aşağıda ayrıntılı verilecek)

frame_relay

Committed Information Rate (CIR):  ISP’nin  aktarmanıza izin vereceği, ortalama miktardır.

Access rate: Frame Relay interface’in aktarabileceği maksimum hız.

Frame Relay Enkapsülasyon Tipleri

İki enkapsülasyon tipi vardır. Cisco ve IETF (internet Engineering Task Force). Cisco router’lar için varsayılan enkapsülasyon “Cisco”  kullanılır. Farklı cihazlar arasında frame relay kullanılacaksa endüstri standardı olan “IETF” enkapsülasyon kullanılır.

Sanal Devreler (Virtual Circuit)

Frame relay sanal devreler kullaranarak çalışır. Frame relay iki tane DTE cihazı arasında sanal bir devre sağlar. (Yukarıdaki resimde Merkez ile her şube arasında sanal devre vardır. (Merkez-şube1, merkez-şube2, merkez-şube3) Parmanent virtual circuit (PVC) ve Switched virtual circuit (SVC) olmak üzere iki sanal devre çeşidi vardır.

Data Link Connection Identifier (DLCI)

Frame Relay PVC’leri ve DTE uç cihazlarını DLCI tarafından tespit edilir. Frame Relay servis sağlayıcısı  farklı sanal devreleri ayırt etmek için Frame Relay interfacelerinde kullanılan DLCI değerleri ip adresi ile eşleştirerek atar ve bu değer ile ayırt eder.

R1(config-if)#frame-relay interface-dlci 16-1007   arası değer servis sağlayıcı tarafından atanır.

Local Management Interface (LMI)

Router’ınız ve onun bağlı olduğu ilk Frame Relay switch arasında kullanılan, sinyalleşme standardıdır. Cisco (varsayılan), ANSI ve Q.933A,  olmak üzere3  farklı LMI mesaj tipi vardır. Bu LMI tipi servis sağlayıcı ile ilgili olup  cihaz tarafından otomatik algılanır(autosense özelliği).

R1(config-if)#frame-relay lmi-type cisco,ansi,q933a (varsayılan cisco)

Sanal devre durumları: Frame Relay switch’inden gelen LMI bilgisi ile sanal devreler 3  farklı duruma geçer.

1-) Active State:  Bilgi alınıp verilmesinde sorun yoktur.Herşey çalışır durumdadır.Relay

2-) Inactive State: Router interface aktif ve bağlanmaya çalışıyor ama uzak router (servis sağlayıcı ile ilgili sorun) çalışmıyor.

3-) Deleted State: Frame relay switchden LMI bilgisi gelmeme durumudur. Eşleşöme hatası veya hat arızasıdır.

Frame -Relay show/debug komutları

show_frame-relay

Router#debug frame-relay lmi

Frame Relay örnek konfigürasyonu

Örnek-1-

FRAME_RELAY_ORNEK_1

istanbul Router

ist(config)#interface serial 0/0/0

ist(config-if)#ip address 10.10.10.10 255.255.255.0

ist(config-if)#encapsulation frame-relay (cisco)(karşılıklı 2 cihaz cisco olduğu için varsayılan cisco enkapsülasyon kullanıldı. Farklı olsaydı ietf seçmeliydim. Bu özellik servis sağlayıcı tarafından belirtilir)

ist(config-if)#frame-relay interface-dlci 100 (DLCI değeri servis sağlayıcı tarafından belirtilir)

ist(config-if)#frame-relay lmi-type ansi (varsayılan cisco, değer servis sağlayıcısı tarafından belirtilir. autosense özelliği aktifse interfarce otomatik algılar )

ist(config-if)#no shutdown

 

izmir router

izmir(config)#interface serial 0/1/0

izmir(config-if)#ip address 10.10.10.20 255.255.255.0

izmir(config-if)#encapsulation frame-relay (cisco)

izmir(config-if)#frame-relay interface-dlci 200

izmir(config-if)#frame-relay lmi-type ansi

izmir(config-if)#no shutdown

Örnek-2-

Subinterface’ler ile çalışmak

frame_relay_ornek_2

İSTANBUL ROUTER

istanbul(config)#interface serial 0/3/0
istanbul(config-if)#no shutdown
istanbul(config-if)#encapsulation frame-relay

istanbul(config)#interface serial 0/3/0.101 point-to-point
istanbul(config-subif)#ip address 10.0.10.1 255.255.255.252
istanbul(config-subif)#frame-relay interface-dlci 101
istanbul(config)#interface serial 0/3/0.201 point-to-point
istanbul(config-subif)#ip address 10.0.11.1 255.255.255.252
istanbul(config-subif)#frame-relay interface-dlci 201

istanbul(config)#interface serial 0/3/0.301 point-to-point
istanbul(config-subif)#ip address 10.0.12.1 255.255.255.252

konya(config-subif)#frame-relay interface-dlci 103
istanbul(config-subif)#frame-relay interface-dlci 301

istanbul(config-router)#network 10.0.10.0 0.0.0.3
istanbul(config-router)#network 10.0.11.0 0.0.0.3
istanbul(config-router)#network 10.0.12.0 0.0.0.3
istanbul(config-router)#no auto-summary

ANKARA ROUTER

ankara(config)#interface serial 0/1/0
ankara(config-if)#no shutdown
ankara(config-if)#encapsulation frame-relay

ankara(config)#interface serial 0/1/0.102 point-to-point
ankara(config-subif)#ip address 10.0.10.2 255.255.255.252
ankara(config-subif)#frame-relay interface-dlci 102

ankara(config-router)#network 10.0.10.0 0.0.0.3
ankara(config-router)#network 10.0.11.0 0.0.0.3
ankara(config-router)#network 10.0.12.0 0.0.0.3
ankara(config-router)#no auto-summary

KONYA ROUTER

konya(config)#interface serial 0/1/0
konya(config-if)#encapsulation frame-relay
konya(config-if)#no shutdown

konya(config)#interface serial 0/1/0.103 point-to-point
konya(config-subif)#ip address 10.0.11.2 255.255.255.0
konya(config-subif)#frame-relay interface-dlci 103
konya(config-router)#network 10.0.10.0 0.0.0.3
konya(config-router)#network 10.0.11.0 0.0.0.3
konya(config-router)#network 10.0.12.0 0.0.0.3
konya(config-router)#no auto-summary

Share