HSRP (Hot StandbyRouter Protocol)

Genel tanım olarak network’te bulunan router’ların yedekli olarak çalışmasını sağlayan cisco’ya özel protokoldür.  (IEEE standartı VRRP’dir) VRRP HSRP’nin daha gelişmiş özelliklerini kapsar. VRRP’nin HSRP’den üstün olduğu en önemli özelliği, HSRP’de bir routerın bir tane yedeği olabilirken,  VRRP de bir routerın birden fazla yedeği olabileceğidir.

Router’da bir sorun olduğu zaman muhtemelen network ağının tamamı veya bir bölümü çalışmayacaktır.  Ama router bağlı hattın bir sorun olması durumunda da aynı sorun yaşanır. Router çalıştığı halde kablo hattında sorun yaşandığından  dolayı bizim network ağımızın bir kısmı veya tamamı devreden çıkacaktır. HSRP bu sorunada çözüm olabilir (HSRP interface tracking). HSRP ile aslında hem router yedekliliği hemde hattın yedekliliği sağlanabilir. İki router arasında sanal bir ip adresi ve mac adresi  oluşturulur. Bu iki router arasında yük dengeleme (Load Balancing) yoktur.

Örnek bir senaryo üzerinden durumu özetlersek.

Bu senaryoda şube ile merkez arasında ADSL fiber ile bağlantı kurulmuştur. ADSL router veya ADSL bağlantısında bir problem olursa devreye lease line Router ve lease line hat girecektir ve böylelikle devamlılık sağlanmış olacaktır. (Yedek hattında ADSL  fiber olması mantıklı değildir. Çünkü fiber hat sorunu çoğunlukla bölgesel olduğu için sorun halinde  diğer yedek fiber hatta devre dışı kalacaktır.)

Standby seçimi:

Hangi router aktif hangi router pasif olacağı aşağıdaki kriterlerle belirlenir.

  • En yüksek ip adresine sahip router default router olarak aktif olur. Ama HSRP priority değeri ile değiştirilebilir. En yüksek HSRP priority değerine sahip router default router olur. (Default priority değeri 100 dür)
  • Router’lar multicast adrese her  3 saniyede bir hello paketi yollar. Aktif router 10 saniye boyunca  hello paketi yollamazsa yedek router devreye girer.

Örnek konfigürasyon

Bu örnek topoloji günlük hayatta kullanışlı ve mantıklı olmasa da, konumuz olan Router ve hat yedekliliği ile ilgili başlangıç olarak  bir çok sorumuza cevap verecektir.

R1 ve R2 master router olacak ve veriler ilk başta R1 ve R2 router üzerinden gidecek. Ama R1 R2 routerlarda veya hatlarında problem olduğunda yedek routerlar devreye girecek. Sorun düzeldiğinde tekrardan kendi üstüne trafiği alacak. Bu ayrımı VLAN bazında da yapılabilir. Şöyle ki vlan 100 ve Vlan 200 olarak 2 farklı vlan yapımız olsun. Vlan 100 için trafik R1 gidecekken vlan 200 R1_yedek üzerinden gidecek. Ama herhangi bir router da problem olması halinde bütün trafiği üstüne alacak.

R1_YEDEK(config-if)#standby 10 ip 10.100.200.1 (Ortak kullanılacak olan sanal ip adresi)
R1_YEDEK(config)#router eigrp 10
R1_YEDEK(config-router)#network 10.100.200.0 0.0.0.255
R1_YEDEK(config-router)#network 192.168.2.0 0.0.0.255
standby 10 preempt

R1(config-if)#standby 10 ip 10.100.200.1
R1(config-if)#standby priority 200 (Default router olması için)
R1(config)#router eigrp 10
R1(config-router)#network 10.100.200.0 0.0.0.255
R1(config-router)#network 192.168.2.0 0.0.0.255
R1(config-if)#standby 10 preempt (Sorun giderildikten sonra trafiği tekrardan üstüne alır)

R2(config-if)#standby 15 ip 10.100.150.1
R2(config-if)#standby priority 200
R2(config)#router eigrp 10
R2(config-router)#network 10.100.150.0 0.0.0.255
R2(config-router)#network 192.168.2.0 0.0.0.255
standby 15 preempt

R2_YEDEK(config-if)#standby 15 ip 10.100.150.1
R2_YEDEK(config)#router eigrp 10
R2_YEDEK(config-router)#network 10.100.150.0 0.0.0.255
R2_YEDEK(config-router)#network 192.168.2.0 0.0.0.255
standby 15 preempt

HSRP Preemption (preempt ): Aktif router kesilirse devreye standby router girer. Aktif router bulunan sorun giderilse bile bundan sonra  trafik genede standby router üzerinden akmaya devam eder. Bu durumu değiştirmek için yani akif routerda bulunan sorun giderildiğinde trafik eskisi gibi aktif router üzerinden devam etmesi için HSRP preemption aktifleştirmek gerekir. Preemption, routerları HSRP seçim sürecini tetikler.

Show komutları:

Show standby

Share